Slow google drive upload speed when passing trought Mikrotik Board.

380 views 1 replies
Reply to Topic
tagdeaxuop

Age: 2023
Total Posts: 0
Points: 10

Location:
,
Hello, I got a weird thing happening on my main PC when I tried to upload some file into my Google Drive account.

So basically I got 50Mbps of upload speed but when I tried to upload to
Drive the always goes down to 5Mbps, at first I thought it was my ISP is
throttling my upload speed to Drive but then I tried to upload to same
Drive account on the same network from my Laptop I got normal upload
50Mbps speed to Drive.
Then I realized there must be something wrong with my setup so I tried multiple things

1. I tried to connect my network cable directly to my ISP router modem
bypassing my RB850Gx2 Mikrotik board and I got normal upload speed to
Drive from my Main PC.
2. I got a spare HAP Lite Mikrotik board so I tried to connect my ISP
router to that board with the most standard minimum setting so I can
connect it to my main PC and also it gave me normal upload speed to
Drive.
3. I reset my main RB850Gx2 mikrotik board so now it got the same
minimum setting just like my HAP lite and connect it to my main PC but
even then the upload speed still got throttled to the same 5Mbps again
only to Drive.

I tried to reset my Windows 10 PC network adapter setting and nothing
works, the only way I can get normal upload speed to google drive from
my main PC is by connecting it to my ISP router or my Hap Lite board
directly.
It's not related to my host file either because if this true then it
shouldn't be fixed just by connecting it directly to my ISP router or
Hap lite board.

I even test by doing this weird setup [ISP router] -> [RB850Gx2]
-> [Hap lite] -> [Main PC] and the upload speed became normal
also.
So basically if i connect my internet directly from my main PC to
RB850Gx2, then my main PC upload to google drive became throttled but
everything else is still normal.

I desperately need help here because the only thing that I haven't done
is reinstallng my main PC windows and I was hoping that won't be the
solution because none of my other devices in the same network got this
problem.

Posted 25 Aug 2022

Reply to Topic